Can anyone locally help me test my ECU? Will buy you lunch!

General car discussion and other related topics of interest for MN 3/S members.
Post Reply
ruiz0052
New Member
Posts: 3
Joined: Mon Feb 17, 2014 3:48 pm

Can anyone locally help me test my ECU? Will buy you lunch!

Post by ruiz0052 » Mon Feb 17, 2014 3:57 pm

Recently i've had some issues that are causing me to believe the problem lies within my ECU. Rather then send it off, would greatly appreciate if someone locally can help me test my ECU by plugging it in their car.

I have 1991 Dodge Stealth RT/TT.

PS as title says will buy you lunch if you can help me out!

niterydr
Senior Member
Posts: 1134
Joined: Mon Apr 19, 2004 9:43 pm
Location: Wayzata, MN

Re: Can anyone locally help me test my ECU? Will buy you lun

Post by niterydr » Fri Feb 21, 2014 12:52 am

What sort of problems are you having?
-Josh
-(blue) 93 rt/tt --sold -720awhp, 11'[email protected]
-(white) 92 rt/tt --SOLD
https://www.facebook.com/CompleteTuningSolutions
-(Green) 03 Kawasaki ZX6RR

ruiz0052
New Member
Posts: 3
Joined: Mon Feb 17, 2014 3:48 pm

Re: Can anyone locally help me test my ECU? Will buy you lun

Post by ruiz0052 » Sat Feb 22, 2014 3:12 am

Its been an intermittent issue in which it began with a CEL code that display TPS although it was new and recently occurred after the ECS went bad. The ECS was unplugged however recently my car on cold start would run perfectly fine and then once turned off and started again, on warm start would begin to misfire and display the TPS CEL code. Eventually car would correct itself and begin driving normal once again. This issue was intermittent for a few days before i decided to open the throttle to about 6000rpms and right after i got off the accelerator, the CEL came back up and started to misfire again. I checked the codes with my logger to find that it pulled a TPS, Ignition system, Ignition timing, EGR, and the anti lock light came on as well. The car misfired for a couple days with me barely driving it and then it corrected the issue by itself. This problem is occurring at irregular intervals and this last Wednsday i pulled the ECU and sent it to AVpro to check it out. This monday i will know more but was hoping to have it checked before i sent it.

Post Reply